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Introduction 

arivis Vision4D is a modular software for working with multi-channel 2D, 

3D and 4D images of almost unlimited size independent of available RAM. 

Vision4D is designed around the central concept that file size should never 

be the issue.  

With the arivis ImageCore technology at its heart, this software is capable 

of opening and rendering multi-terabyte sets almost instantly, without the 

need for expensive hardware of extraordinary specification.  

This Quick Start Guide is intended as a first point of contact for novice us-

ers with the software and not as a replacement for the full manual and help 

files that are included with all installations.  

As such, many intricacies and subtitles of the operation of the software are 

omitted from this guide and users are encouraged to refer to the help file 

and manual if this guide does not fully answer their questions. 

Remember that as with other Windows software packages, pressing the F1 

key on your keyboard calls up the Help files.  

In arivis Vision4D, this shortcut is context sensitive and will load the help 

page for the current tool or window. 

Users are also encouraged to work through the examples and exercises 

with the available demonstration data that can be downloaded from 

http://demodata.arivis.com before attempting to process their own images 

to gain some familiarity with the tools and functions prior to handling 

complex problems.  

Because many of the terms used in this guide are technical and some are 

unique to the arivis Vision4D workflow, users are encouraged to familiarise 

themselves with these terms. We have included a glossary at the end of this 

guide with links throughout the document to definitions of these terms. 

  

http://demodata.arivis.com/
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The SIS file format and ImageCore technology 

The arivis ImageCore is a powerful software library which provides fast and 

smooth retrieval of stored images independent of size and zoom level. 

The concept of the arivis ImageCore aims at transparently providing appli-

cations with highly performant memory. For this, different caching and 

pre-fetching strategies are combined with an optimized data format and 

efficient methods for accessing the data. Because ImageCore is essential to 

the way that arivis Vision4D handles image data, all non-native files that a 

user wishes to open in the software for processing and analysis must first 

be converted to the SIS format.  

For native files (*.SIS files), this process is not necessary and users can 

simply select to open a file to display and process it almost instantane-

ously.  

Please see the section below on opening and importing for the practical 

implications of this aspect of the software. 

 



 

1. The arivis Vision4D interface  

The arivis Vision4D interface consists of one or more Viewers. Each Viewer 

can display one SIS file and is constructed from several individual elements 

that are assembled to give users access to all the tools and functions re-

quired to process and analyse images as well as providing a rendering 

space for visualising image data.  

In the snapshot below, you will find the main components of this interface. 

Menus – provide access to all the interface elements, tools and functions. 

The Shortcut toolbar – provides access to commonly used tools and func-

tions through icon buttons. The Shortcut Toolbar is context sensitive and 

will offer a different selection of shortcut buttons depending on the image 

rendering mode (e.g. view orientation in the 4D viewer). 

The Viewing Area – where images are rendered for the user to interact with. 

The Viewing Area can be split to display multiple sets or image views 

The Viewer Settings toolbar – positioned at the bottom of the Viewing Area, 

it provides tools specific to the specific viewer type currently being used as 

well as shortcuts to commonly used elements (e.g. enable or disable dis-

play of annotations and window decorations), and also include the Viewer 

Types Pane to quickly switch between viewer types. 

Palettes Sidebar – Positioned to the right of the Viewing Area, the palettes 

sidebar displays individual palettes. Palettes provide groups of information 

and settings elements relating to certain aspects of rendering and display. 

Viewer Types Pane 

Palettes 

Shortcut toolbar 

Viewer Settings toolbar 

Menus 
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Palettes can be undocked and moved to other screens to provide more ren-

dering space for the images. Palettes are context sensitive and some pal-

ettes are displayed automatically when changing rendering modes. Other 

palettes can be accessed from the Window menu or by right-clicking with 

the mouse on empty palette space.  

1.1. Access to Palettes  

Right-click on empty palette space to access the Palettes menu where you 

can enable or disable all available palettes. 

Note that some interface elements are only available depending on your 

license configuration (e.g. the Colocalization panel is only available if you 

have purchased this specific option) 

1.2. Handling Viewers 

 

Viewers allow users to display their images, They offer various options in 

terms of rendering mode and multiple viewers can be opened simultane-

ously. 
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To switch rendering modes within a viewer, or to view the files information, 

users can simply select the type of viewer they wish to use either by click-

ing on its icon in the bottom left of the  Viewer Settings Toolbar, or by se-

lecting it from the View menu. 

 

Switching between multiple viewers can be done by clicking anywhere 

within the viewer window that you want to activate, selecting it from the 

taskbar, or by selecting the desired viewer from the Window menu. 



 

2. Opening Image Files 

The simplest way to open an image file in arivis Vision4D is to simply drag 

and drop the file you want to open from the Windows Explorer into the 

arivis Vision4D Viewer window. Native files will open immediately and non-

native files will automatically be imported. For more complex imports and 

more options in opening and importing files, see below. 

 

2.1 Opening Native (SIS) Files 

As explained in the section concerning the arivis ImageCore technology 

above, only native files can be opened, visualised and processed in arivis 

Vision4D.  Non-native files need to be converted through the import pro-

cess to be opened. 

To open an existing SIS file, you can drag and drop it into a viewer as de-

scribed above 

Alternatively, go to the File menu and select the Open-option, or select the 

  icon from the shortcut toolbar.  

 

 

 

1. In the Open dialog, navigate to the file you wish to open and select it 

by clicking on it.  
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2. Then, either double click the file or click on the Open button to open 

it. 

Note that only files with the .sis extension, for image files, or .py for 

scripts, will be displayed in this window by default. If the file you are 

looking for is not shown, you may need to use the Import function in-

stead. 

 

2.2 Importing non-native formats 

Depending on the complexity of the structure of the imported files and 

whether you are importing a series of files or a single document, the im-

porting process can offer different options and levels of complexity. Exam-

ple files for each of the following types of import can be found in the demo 

data at http://demodata.arivis.com. 

 

For practice, see exercises at the end of the guide. 

 

2.2.1 Single file import 

Supported set file formats (CZI, LIF, ND2, OIF etc.) and single images can 

be imported very quickly and easily.  

Either click and drag the selected file from the Windows Explorer into the 

arivis Vision4D workspace or go to the File menu and select the Import… 

option. 

http://demodata.arivis.com/
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In the Open dialog, navigate to the file you wish to open and select it by 

clicking on it.  

 

Then, either double click the file or click on the Open button to open it. 

Note that all supported image format files will be displayed in this win-

dow. You can restrict the type of image files to display by selecting them 

from the drop-down list immediately above the Open button. 

You will then be presented with the Import dialog where you can choose 

name and location for the resulting SIS file. 
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1. Select the desired save location by clicking on the Folder drop-down 

selection box and choosing your preferred save location. 

Note that this selection box defaults to the last selected save location. 

Other save locations can also be selected by clicking the Browse button. 

The current location of the files to be imported can also be selected from 

this list. 

2. Select the desired name for the output file.  

Note that the import will propose the original name by default but will re-

place the original file extension with .sis.  

3. Then click Import to import the files and create a new SIS file from 

the selected image. The imported file will automatically open.



 

2.2.2. Multiple file import – simple image series 

When opening multiple image files that are part of a series, or files that 

contain multiple images, some further configuration will be required to de-

fine the dimension order. 

To import a series of images, go to the File menu and select the Import op-

tion. 

1. In the Open dialog, navigate to the files you wish to open and select 

them by clicking on them. (1) 

You can use the keyboard shortcut Ctrl-A to select all the files in the cur-

rent folder. You can also use the Shift and Ctrl keys while clicking to se-

lect multiple contiguous or non-contiguous files respectively. 

Note that all supported image format files will be displayed in this win-

dow.  

2. You can restrict the type of image files to display by selecting them 

from the drop-down list immediately above the Open button. (2) 

3. Then, click on the Open button to open the series. (3) 

 

1 

2 

3  



 

You will then be presented with the Import dialog where you can choose 

the name and location for the resulting SIS file, and the structure of the set.  

1. For simple time series or Z-stacks, you can select the appropriate 

option from the common scenarios list. (1) 

2. Select the desired save location by clicking on the Folder drop-down 

selection box and choosing your preferred save location. (2) 

Note that this selection box defaults to the last selected save location. 

3. Other save locations can also be selected by clicking the Browse but-

ton. 

Select the desired name for the output file. (3) 

Note that the import will propose the original name by default but will re-

place the original file extension with .sis.  

4. Then click OK to create a new SIS file from the selected images and 

open it. (4)  

1 

2 
3  

4  
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2.2.3. Multiple file import – complex image series 

arivis Vision4D supports importing files with multiple dimensional ele-

ments.  

In most cases, when opening set files from supported providers (LSM, LIF, 

CZI etc.), multiple dimensions are automatically processed into their recipi-

ent dimensions in arivis Vision4D.  

Please refer to single file imports for these cases.  

However, if importing sets with multiple dimensions from image series, 

manual configuration of the dimensional arrangement will be required. 

1. To import a complex series of images, go to the File menu and se-

lect the Import… option. 

2. In the Open dialog, navigate to the files you wish to open and select 

them by clicking on them  

You can use the keyboard shortcut Ctrl-A to select all the files in the cur-

rent folder. You can also use the Shift and Ctrl keys while clicking to se-

lect multiple contiguous or non-contiguous files respectively. 

Note that all supported image format files will be displayed in this win-

dow. You can restrict the type of image files to display by selecting them 

from the drop-down list immediately above the Open button.  

3. Then, click on the Open button to open the series. 

4. If importing more than 100 files, you will then be prompted to 

choose whether you wish to assume the same structure for all files.  

5. Select Yes if appropriate. 
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You will then be presented with the Import dialog where you can choose 

the name and location for the resulting SIS file, and the structure of the set. 

1. Select the desired save location by clicking on the Folder drop-down 

selection box and choosing your preferred save location. (1)  

Note that this selection box defaults to the last selected save location. 

Other save locations can also be selected by clicking the Browse button. 

2. Select the desired name for the output file.  

Note that the import will propose the original name by default but will re-

place the original file extension with .sis.  

3. For multiple tiles of an image mosaic, select the Tile sorter scenario 

and see section 5.c for details of the Tile sorter. (2)  

4. For multidimensional sets, scroll down the import scenario list and 

select the Custom import option and click OK. (3)  

5. For simple time series or Z-stacks, see section on importing simple 

series above.

  

1 

2 

3  
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You will then be presented with the Manual import mapper dialog. 

In the Manual import mapper dialog users are presented with a grid of the 

image indices along the Y axis and their input and output coordinates 

along the X axis.(1)  

2.2.4. Pattern Matching 

If the image names include details of their respective dimensional coordi-

nates (e.g. ImageSet_C001_T002_Z005 where the number following the di-

mensional identifier characters defines its position along this dimension), 

you can use the Pattern matching function to allow the software to arrange 

all the images into their correct positions.  

To do this, go to the Selection menu and select the Pattern matching… op-

tion. (2) 

Note that the operation will apply to all images unless a sub-selection has 

been made. In that case, the operation will be applied only to the sub-se-

lection 

1 

2 

3  
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You will then be presented with the Pattern matching dialog below. 

1. Use the pattern definition nomenclature at the top of the dialog to 

update the Pattern matching string (1) 

2. Then click the Refresh button to update the Preview pane (2), (3). 

3. If necessary, it is possible to edit offsets using the Edit offsets but-

ton (4) 

4. When satisfied with the results, click OK to confirm. 

 

Please refer to the help file for a further details. 

 

Remember you can use the F1 key on your keyboard for quick access to 

the help page on any topic. 

 

1 

2 

3 

4 



 

2.2.5. Apply Dimension Order 

If the file name gives no indication of the image coordinates, or if the im-

ages are extracted from a multiple image document (e.g. OME TIFF), you 

will need to manually select and define the dimension and their order.  

 To do this, go to the Selection menu and select the Apply Dimension 

Order… option.  You will then be presented with the Apply Dimension 

Order dialog below. 

The Apply Dimension Order is split into 2 sections.  

 The upper section lists the currently selected dimensions and their 

extent, the lower part previews the image coordinates. The most 

common two dimensions are automatically added to the initial di-

mension list.(1)  

1. To add dimensions, click on the Add dimensions button.(2) 

 To modify the dimension type, select a new type from the 

drop-list box on the left of the dimension you want to modify. 

 To modify the dimension extent, type desired extent in the 

textbox in the centre of the dimension you want to modify. 

 To modify the dimension order, click the Up / Down button on 

the right of the dimension you want to modify. 

 To remove a dimension, click the Remove button next to di-

mension you wish to remove.  

1 

2 

3 

4 
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Note that at least one dimension must be present and by default the first 

dimension cannot be removed. If the first dimension is incorrect, you 

should modify it rather than remove it. 

Some trial and error may be required unless you already know the dimen-

sion order.  

2. Update the image coordinate preview by clicking the Update Preview 

button at the bottom of the dialog to verify your input. (3); (4) 

3. Adjust each dimension as needed, then click OK to confirm your se-

lections and return to the Manual import mapper.  

4. Click Open to complete the set definition and import the selected 

images into your new SIS file. 

 

Note that it is also possible to manually edit all these parameters within 

the Manual Import Mapper. Please refer to the help files for more details. 
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2.3. Tile Sorter 

arivis Vision4D includes tools to rearrange tiled images into a large mosaic 

and adjust the alignment of images tiles/stacks. The image import de-

scribed above allows you to import images directly into the Tile Sorter tool, 

but this tool can also be accessed after the image import has been com-

pleted as a separate step from the Data menu. 

Note that the Tile Sorter takes a stack of images as input. If the chosen 

images are not imported directly into the tile sorter from the import sce-

nario dialogs they must first have been imported as a single Z-stack or 

organized as tile stacks in the frames or scopes of the dataset. 

 

The Tile Sorter dialog is composed of several discreet elements: 

Target Dataset definition – where users define the number of frames and 

planes expected in the output scope and their order.(1) 

Sort Mode – where users choose how to sort the tiles, whether in a grid pat-

tern, manually or by applying an alignment algorithm. (2) 

1 

2 

3 

4 

5 

6 
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Columns and Row definition – where users select the number of rows and 

columns, and defines their spacing and orientation. This section is depend-

ent on the type of operation chosen. It is hidden in the manual alignment 

and offers different tools for automatic alignment. (3) 

Tile Sorter Preview – where users can see in real time the effect of tiling 

adjustments. (4) 

Tile Sorter Viewer Settings toolbar – which functions similarly to the main 

Viewing Area Settings Toolbar in giving the user the option to change how 

the tiles are displayed. (5) 

 

To access the Tile Sorter during import, simply select the Tile Sorter scenario 

from the import scenarios.  

If you already have your mosaic tiles opened as an SIS file in arivis Vi-

sion4D you can access the Tile sorter by going to the Data menu and se-

lecting the Tile Sorter option. 

In general, the tile sorting process is as follows: 

1. Users align the images using basic sorting by grid. 

2. Manually refine the alignment (if needed or if the tiles are not ar-

ranged by grid). 

3. If necessary, users can then further refine the alignment using pat-

tern matching to correct for slight errors in positioning from tile to 

tile. 

4. Once the alignment is finalised, the stitched image can then be gen-

erated and saved. 

 

Grid tile positioning  

As most mosaic tiles are acquired using automated tiling systems with 

motorised stages, the simplest method for aligning the image correctly for 

stitching is to use the grid sort mode. The grid mode works by defining the 

number of frames, planes, rows and columns and then rearranging the im-

ages into their order of acquisition. 

1. First, select the number of frames and planes in the resulting scope. 

(1) 

2. Then, select the grid option from the Sort Mode column. (2) 

3. Adjust the Columns and Rows values until the preview image resem-

bles the expected results. (3) 

4. You may also need to adjust the Order and Starting at options to get 

the desired results. (3) 
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5. Once the tiles are sorted into the correct order, you may need to ad-

just the overlap and displacement options to get a perfect match be-

tween images. (3) 

6. To do this, it is recommended that you should zoom to the intersec-

tion between four tiles at 1:1 zoom level using the Viewing Area set-

tings toolbar. (5)  

7. Then, adjust the overlap and displacement values until the tile over-

lap becomes seamless. Hiding the grid display may help at this 

stage, this can be done by deselecting the Grid checkbox in the 

Viewing Area settings toolbar. 

 

You can also toggle the visibility of the currently selected tile with the 

Space key 

 

Manual tile positioning 

In case where the tiles to be merged were acquired using manual posi-

tioning of the stage, using a manual placement of the images on the 

screen may be more effective. This positioning does not need to be per-

fectly accurate as it can be finished off using automatic alignment. 

1. First, select the number of frames and planes in the resulting scope. 

(1) 

2. Then, select the Manual option from the sort mode column. (2) 

3. Click and drag individual frames in the tiling workspace to their ap-

proximate locations relative to each other. 

4. Then, adjust the overlap and displacement of the images by clicking 

on the tile whose position you are looking to adjust and using the 

arrow keys on your keyboard to move it up, down, left or right until 

the tile overlap appears seamless. Changing the selection transpar-

ency may help at this stage, this can be done by adjusting the Selec-

tion Transparency slider in the Viewing Area settings toolbar. 

 

Alignment calculation 

Having set up the tile positions, either manually or using the grid align-

ment, some slight misalignment of frames may still be present. Arivis 

Vision4D includes automatic matching tools to get the alignment pixel 

perfect prior to blending the tiles. 

1. Select the alignment option from the Sort mode column. 

2. Choose a maximum horizontal and vertical alignment limit. This will 

limit the margin of error in case the overlap pattern is weak. Setting 
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a larger alignment margin also means the alignment process can 

take longer. 

3. Choose an alignment algorithm and your preferred optimiser 

4. When ready, you can choose to Align Current Plane and assume that 

each stack is well aligned with the next, or use the Batch Alignment 

to calculate the alignment for some or each plane in the stack. 

 

Consult the help files for a more details on the alignment options. 

 

 Remember you can use the F1 key on your keyboard for quick access to 

the help page on any topic. 

 

Once the tiles are sorted and aligned, you can complete the process by 

clicking the Create Stitched Planes… button.(6)  
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1. You will then be prompted to choose the Region to process (if you 

do not wish to process every plane in a stack, for example) (1) 

2. Choose the desired Output. (2) 

The stitched image can be saved to a new scope within the current file, or 

as a new separate file altogether. If selecting a new file, you will also need 

to select the output file’s name and location.  

3. Select your options as desired and click Finish to produce your tiled 

sorted scope. 

 

For full details, please refer to the Help files.  

 

Remember you can use the F1 key on your keyboard for quick access to 

the help page on any topic. 

  

1 

2 
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2.4. Editing metadata 

In some instances, the metadata relating to an image may be incorrect or 

missing. 

While in many cases missing metadata does not affect the visualisation or 

analysis of the images, it is particularly important that the pixel spacing in-

formation is correct in every case as this is used to calibrate the rendering 

of the image and measurements of annotations. 

 To edit pixel dimension values, go to the Data menu and select the 

Pixel size… option. 

1. In the Pixel size window, select the required value for each dimen-

sion, making sure that you select the correct units.  

2. Click Change Pixel Size when ready to apply changes.  

 

Hint: units can be selected simply by typing out the full value including 

units. In that case “µm” can also be written out as “um” 

 

Remember to save your file after applying these changes to avoid having 

to make these changes next time you open this file. 
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3. Image visualisation 

Because large datasets typically have more information than can be dis-

played on the screen at any one time, choosing the most appropriate ren-

dering mode is an essential part of the workflow.  

The viewer types available in arivis Vision4D are 2D, Gallery, 4D, Info and 

Projections.  

Each viewer type is particularly suited to different kinds of images and 

workflows. 

 The 2D view is ideally suited to sets that do not include depth infor-

mation or to processing images within an analysis workflow where 

users need to interact with annotation and see the results of opera-

tions at full resolution. 

 The Gallery view allows users to see all plane images and/or frames 

from a scope in a grid arrangement and can be useful for navigation 

in conjunction with the Split View. 

 The 4D viewer is best suited to visualising sets with volume infor-

mation and looking at the structures within them, but is not well 

suited to the manual definition of regions of interest. 

 The Info viewer offers information about the data set, and allows the 

user to change the dataset structure (e.g. remove planes, remove re-

sults scopes or edit scope offsets). 
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3.1. Switching view modes 

Switching viewer types is fast and easy in arivis Vision4D.  

1. To do this, simply click on the icon referring to your preferred mode 

in the Viewer Settings toolbar. (1) 

2. These options are also available from the View menu. (2) 

  

1 

2 
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3.2. 2D Viewer 

The 2D view is a great rendering for examining 2D data or looking at indi-

vidual portions of the set with the highest degree of detail by giving direct 

access to the raw pixel data. It is also a very useful view for testing out data 

analysis operations prior to executing them on complete stacks. 

 To activate the 2D viewer, simply click its icon in the Viewer Types pane 

Viewer Settings toolbar. 

Because by its nature the 2D viewer restricts the amount of information that 

can be displayed at any one time to a single plane, arivis Vision4D offers 

several tools to allow the user to navigate through the set to focus on specific 

portions of the image data. 
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3.2.1. The Navigator palette 

The Navigator Palette is a useful tool for quickly navigating through the 

set’s dimensions.  

It is context sensitive and displays navigation tools for each of the available 

dimensions, except for channel. Tools are only displayed if the current set 

has an extent greater than 1 for that dimension. This means that if your file 

only contains 1 scope, the scope selection list will not be displayed. 

The droplist box at the top allows the user to navigate through scopes (1). 

Simply select the scope you wish to view from the list to activate it. 

The image Navigator preview shows the current view area are in the con-

text of the current plane. (2)  

The sliders on the right and bottom allow you to scrub through planes and 

frames respectively (3)&(4) 

1 

2 3 

4 
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Users can also drag the current view area on the Navigator preview to navi-

gate to this portion of the image in the viewer, or click and drag outside of 

the current view rectangle to adjust the viewer to the selected area. 

 

3.2.2. Zooming and panning 

 To zoom in on an image in the 2D view, you can use your mouse scroll 

wheel or the various zoom tool from the shortcut toolbar.  

 With the magnifying glass tool, left-click on the image to zoom in, or 

hold down the Shift key when clicking to zoom out. 

 You can also drag a rectangle on the image to zoom to that specific 

area. 

 To pan across the image, you can use the scroll bars on the right and 

bottom of the Viewing Area, or the Hand tool from the shortcut toolbar. 
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3.2.3. Navigating through planes 

Navigating through planes can be done in several ways.  

Users can use the Navigator palette as described above, or use the dedi-

cated icons from the shortcut toolbar. The icons are greyed out if it is not 

possible to move further in the button’s navigation direction. 

 

  

 
The Go To Top Plane button display the first plane in the stack.  

 
The Plane Up button display the plane immediately above the cur-

rent plane. 

 
The Plane Down button displays the plane immediately below the 

current plane. 

 
The Go To Bottom Plane button displays the last plane in the stack. 
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3.2.4. Navigating through frames 

Navigating through frames can also be done in several ways.  

As with navigating through depth, the most accessible way is to use the 

Frame slider at the bottom of the Navigator palette.  

The Movie Player palette is another great tool for navigating through time 

frames.  

 To activate it, right-click in an empty space of an existing palette and 

select it from the contextual menu. Alternatively, you can activating by 

going to the Window menu and selecting it from the Palette submenu. 

The buttons along the top allow you to: 

 
Play all frames from the current frame in reverse order. 

 
Step to the previous frame. 

 
Pause the navigation. 

 
Step to the next frame. 

 
Play all frames from the current frame in forward order. 

 
Toggle looping through the sequence. When active the player 

jumps back to the first frame after the last frame is displayed. 

 

Toggle automatic play directions reversal. When active, the player 

reverses play order after reaching either extremity. 

 

The combo box on the top right allows you to change the frame display 

time.  

Users can either select a pre-set from the list or manually type their de-

sired display time.  

 To play the sequence at 10 frames per second, you would need to set 

the display time to be 1s/10 = 0.1s (or 100ms)  
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3.2.4. Color scale and LUT adjustments 

arivis Vision4D offers a range of tools for color and contrast adjustment to 

help users best show their data.  

Several tools for image adjustments are displayed in the workspace by de-

fault, while others can be accessed through the palettes. 

The main tools for image adjustments are the Color Bar (1), Color Sliders 

(2) and Channel Visibility (3).  

When opening images for the first time in arivis Vision4D, the display range 

from the source will automatically be applied if it can be read, otherwise it 

will automatically be set to the dynamic range of the image. If a different 

display range is required, it can be adjusted. 

The fastest and most efficient way to get a good approximation of the best 

display range for the image is to use an automatic display range selection. 

  

4 

1 

2 

3 
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The Shortcut toolbar has two buttons for automatic display range calcula-

tion. (4)  

 Perform Plane Auto Color Range uses the brightest and darkest pix-

els from the current plane in the stack to calculate the upper and 

lower saturation points.  

 Perform Global Auto Color Range uses pixel values from the com-

plete stack to make the same calculation. Because the Plane auto 

colour range uses a much more restrained data set it is much faster, 

but also prone to inadequate results if the selected plane is not rep-

resentative of the stack.  

Note: Global auto color range is slower, and more so if the stack is larger, 

but generally performs better. In either case, the calculation may not fit 

your specific data set and further adjustments may be necessary. 

3.2.5. The Color Bar 

The color bar scale is the most accessible and often most useful tool to ad-

just intensity rendering in images and is shown automatically on the right 

of the Viewing Area. 

It can be shown or hidden by selecting the Show Color Bar option from the 

View menu or by using the Toggle Colour Bar button from the Shortcut 

toolbar. 

1. To adjust the high or low saturation points (black and white levels), 

click and drag the sliders at either end of the scale. 
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2. To adjust the colour tint, right click on the colour scale and select 

the preferred colour from the available pre-sets.  

The pre-set colour ranges included cover the three primary colours of 

Red, Green and Blue, along with the back to white greyscale and rainbow 

colouring.  

Where possible, arivis Vision4D will use the available image metadata to 

automatically display the images in the colour corresponding to what was 

set in the acquisition software.  

If unavailable of incorrect, users can also choose to manually select the tint 

colour to match the wavelength by selecting the Wavelength pre-set and 

entering the wavelength of the selected channel.  

arivis Vision4D will automatically adjust the colour bar to the images’ data 

range (from 8 to 32bit).  

For images taken with a 10, 12, or 14bit camera, you can select these bit 

depth automatically from the Scale Mode sub menu. 

3.2.6. Color Sliders Palette 

While display range adjustments are often all that is required to enhance an 

image for visualisation, other tools can also be useful. 

The Color Sliders palette offers additional tools for brightness, contrast and 

gamma adjustments. 

To activate the Color Sliders palette, right-click on empty palette space and 

select it from the contextual menu or select it from the Window > Palettes 

menu. 



39 

 

 

1. As with other slider based tools, simply click and drag each slider to 

make changes. Changes are applied live on the image.  

2. Click on the Advanced Options dropdown for the ability to adjust 

each channel individually if needed and to apply changes to the cur-

rent plane or complete stack.  

 

Note that these settings affect the rendering of the images in all the dif-

ferent viewer types , so changes made in the 2D Viewer will also appear in 

the 4D Viewer and vice versa.  

 

Please refer to the help files for a more complete breakdown of the color 

slider palette functionality.  

Remember you can use the F1 key on your keyboard for quick access to 

the help page on any topic. 

The 4D Viewer also has rendering settings that pertain specifically to this 

type of rendering.  

For more info, see below in the 4D Viewer section 

3.2.7. Channel Visibility 

While showing multiple image channels overlaid on top of each other is a 

useful tool, sometimes visualisation and analysis is best done with fewer or 

just one channel displayed. 

 To show or hide individual imaging channels, use the Channel Visibility 

palette. 

 To show or hide a channel simply check or uncheck the check box next 

to the channel you want to affect. 
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Note that most of these adjustments affect the rendering of the image in 

other viewing modes such as the 4D Viewer and Gallery view but are spe-

cific to one viewer only. With multiple viewer opened, adjusting color 

range and visibility will affect that window only. 



 

3.3. Gallery view 

The Gallery view allows you to display all images in a stack side by side. In 

conjunction with the split view, it can be a useful tool for navigating 

through a set. To activate the Gallery view, simply click its icon in the View-

ing Area toolbar.  

 

Once activated, the Viewing Area should look like this: 

The Viewing Area toolbar will automatically update to show you tools and 

options relevant to the Gallery view. (1) Here you can choose whether each 

panel in the gallery corresponds to a plane at the current frame or a frame 

at the current plane. You can also select to view every frame and plane in a 

multidimensional stack.  

1. Simply click on the Show in Gallery drop list box and select your 

preferred viewing option. (2) 

3 

1 

2 
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2. Use the Thumbnail Size slider to change the thumbnail magnifica-

tion. (3) 

3. To activate a frame or plane, simply click on it in the viewer. If using 

this with linked viewers in the split view, this plane will also be acti-

vated in any linked viewer.



 

3.3.1. Loupe tool 

You can use the Loupe tool to see a portion of the thumbnail at full magni-

fication.  

 To activate the loupe tool, click on the Loupe icon in the shortcut 

toolbar.  

Then, drag your cursor over the panel you want to examine to see a 1:1 zoom 

of the section of the image under your cursor. 

You may use the mouse scroll wheel to zoom the loupe view.
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3.4. 4D Viewer 

The 4D Viewer is an interactive environment for getting visual insights into 

3D data sets.  

It is called the 4D Viewer because it also allows the visualisation of time 

dependent data in 3D. Because the visualisation perspectives are essentially 

infinite, the 4D Viewer offer several tools to manipulate 3D sets. 

 

To activate the 4D Viewer, simply click its icon in the Viewer Types Pane or 

select it from the View menu options.  

 

Once activated, the viewing area should look something like this: 

3.4.1. Volumetric/Max intensity rendering modes 

The 4D Viewer has two main rendering modes available, the so called Max-

imum Intensity and Volumetric options.  

1 
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It is also possible to hide the volume data to only show elements such as 

annotations and clipping planes. The rendering mode can be selected from 

the Viewing Settings Toolbar (1) 

 The Maximum Intensity rendering mode works by displaying the 

brightest pixel in the axis of observation of the 3D volume. 

 The Volumetric rendering mode integrates the color and transpar-

ency of the visible data. Using a virtual light source, volumetric ren-

dering provides a shaded and semi-transparent data representation. 

Because each rendering mode has a significant impact on the visibility of the 

intensity information in the image, each is more suited to certain types of 

visualisation requirements.  

The Maximum Intensity mode is better suited for the observation of the 

inner structures of objects (e.g. cells in tissue or organelles in cells), while 

the volumetric rendering is somewhat better suited to the visualisation of 

surfaces (e.g. organs).  

However, the rendering mode is usually a matter of personal preference. In 

either case, further adjustment of the rendering parameters may be useful 

or necessary. 
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3.4.2. Adjusting render setting 

As seen in the 2D Viewer, adjusting LUT settings can have a big effect on 

the appearance of the image in the viewer.  

In the 4D Viewer, additional settings are available that are specific to this 

rendering mode to further allow you to tune the visualisation to best match 

your needs.  

The 4D Channel Settings palette opens automatically with the switch to the 

4D Viewer, but can be opened like any other palettes if it has been closed.  

 

 

1. In the 4D Channel Settings palette, first select which channel to ad-

just. By default the mapping is based on the pixel intensities, but it 

can be changed to map the 3D dimension axis and can also be in-

verted. In most cases, Intensity mapping is the preferred option. (1) 

2. Below the mapping options you’ll find the opacity curve. The opacity 

curve is used to map the opacity (Y axis) against the intensity (X 

axis) of the pixels. (2)  

By default, the curve is set match the rendering mode. For Volumetric 

renderings it is a straight line, whereas for Maximum Intensity Projection 

rendering it is set to a curve. 

 The opacity curve can also be manually adjusted by  

 Clicking and dragging on the line anchor points (grey circles) 

 Additional anchor points can be added to the opacity curve for more 

flexibility by 

1 

2 



47 

 

 

 Holding down the Shift key and clicking away from existing 

anchor points 

 Extraneous anchor points can be removed by 

 Holding down the Shift key and clicking on the point to be re-

moved. 

 The entire curve can be shifter left or right by clicking and dragging 

in the curve window outside of existing anchor points. 

 The opacity of the entire volume can be adjusted by using the slider 

to the right of the curve window. 

 

For more details on the 4D Channel Setting palette, please consult the help 

files.  

 

Remember you can use the F1 key on your keyboard for quick access to 

the help page on any topic. 
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3.4.3. Volume manipulation tools 

The 4D Viewer makes use of a variety of tools to allow the user to interact 

with the volume rendering, such as zooming, panning, flying in and out of 

the object, etc. 

The main 4D Viewer navigation tools are: 

  

 Rotate The Rotation Tool is the default navigation tool of 

the 4D Viewer. Its primary mode is rotating the da-

taset by moving the mouse while holding down the 

left mouse button.  

 Zoom The primary mode of the tool is zooming in and out 

of the dataset by moving the mouse up and down, or 

left and right while holding down the left mouse 

button. 

 Panning The primary mode of the tool is moving the dataset 

in a lateral fashion by moving the mouse while hold-

ing down the left mouse button.  

 Fly-Through Used in conjunction with the keyboard, this tool al-

lows the user to virtually fly through the object in 

any direction and orientation. 

 Selection The purpose of the Selection Tool is two-fold:  

 Left-clicking on Annotations or Geometry 

Objects allows you to select these objects. 

Right-clicking anywhere within the viewer 

will deselect all objects. 

 Holding down the Left Mouse Button or Right 

Mouse Button while pointing at a Clipping 

Plane allows you to rotate and move that 

plane respectively. 

 Split tool This tool helps you split annotations that should be 

two instead of one. 
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3.4.4. Rotating, zooming and panning 

As soon as you switch to the 4D Viewer the images will be rendered in three 

dimensions and you can immediately start interacting with the image. 

1. Click and drag on the image in the Viewer to change the orientation. 

Dragging the set up and down rotates the object along the Y axis 

(horizontal rotation), while dragging left or right rotates the object 

along the X axis (vertical rotation). (1) 

 To zoom in or out, use the scroll wheel on your mouse or 

scroll action on your trackpad. 

 Press the Shift key on your keyboard while zooming or chang-

ing the orientation for more delicate manipulation. 

2.  Switch to the Panning tool to drag the 3D view across the screen 

without rotating. The Panning tool can be selected from the Shortcut 

toolbar. (2) 

 As with the zooming and rotation, use the Shift key while 

dragging for fine adjustments. 

  

1 

2 3 
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3.4.4. Jump to orientation 

Because of the almost infinite degree of variation in orientation and zoom 

level, the 4D Viewer has several pre-set orientations to choose from in the 

Shortcut toolbar. (3) 

These buttons allow you to quickly switch to: 

 
Home View – the default orientation and zoom when images are 

first rendered in the 4D Viewer. 

 Front View – looking at the object along the Y axis 

 Top View – looking at the object along the Z axis 

 Left View – looking at the object along the X axis 

 

From these pre-set views, users can proceed to change the orientation as 

usual 

.



 

3.4.5. Bookmarks 

Additionally, arivis Vision4D allows the saving and restoring of Bookmarks. 

Bookmarks help you to record interesting views of your data and to save or 

share them as needed. They capture the current scene settings (e.g. render 

mode and view properties) and store them for later use.  

Bookmarks are stored in the metadata of the document and can be shared 

by exporting them to a proprietary file format (*.bookmarks) for use with 

other sets if needed. 

To open the Bookmarks palette, click on the bookmark icon  in the 

Shortcut toolbar or select it from the View menu. (1) 

Once activated, the Bookmarks palette will appear on the left of the viewer.  

1. Add bookmarks by clicking on the green + icon in the bookmarks 

toolbar. (2) 

2. Each new bookmark will appear within the Bookmarks palette space. 

(3) 

 

1 

2 

3 



 

3.4.6. Bookmarks Palette 

The bookmarks palette toolbar offer the following functions: 

 Restores the bookmark that is currently selected in the list below. 

Alternatively, you can double-click on any given bookmark in the list 

to restore it.  

 

Creates a new bookmark from the current view and scene settings.  

 

Updates the selected bookmark with the current view and scene set-

tings.  

 

Removes the selected bookmark.  

 

Allows you to import a .bookmark file, adding all bookmarks con-

tained in the selected file to the bookmark list.  

 

Exports the current list of bookmarks into a .bookmarks file.  



 

3.4.7. Fly through mode 

When trying to visualise the inner structure of objects, the region of inter-

est may be obscured by the object envelope. One way to visualise these 

obscured structures is to virtually fly through the sample for a closer look 

at the structures of interest. 

This tool is the most versatile navigation tool of the 4D Viewer, offering six 

degrees of freedom in motion using a set of keys as well as the mouse.  

 

 To begin using the Fly-Through Tool, select its icon  from the 

Shortcut toolbar and click once in the centre of the viewer area us-

ing the left mouse button.  

 The mouse is now 'caught' by the viewer and contrary to the other 

tools, it is not required to hold down the mouse button for interac-

tion, simply click the mouse again to release it.  

 Moving the mouse while it is caught allows you to look around.  

 To move around your dataset you can use the arrows keys on your 

keyboard. Alternatively you can utilize the more advanced key setup 

which offers the full functionality of the Fly-Through Tool as below.  

 Use the Shift key together with the movement keys for faster move-

ments. 

 Click the mouse again to release it 

 

 

These are the keys to using the Fly-Through Tool depending on  the Input 

Mapping.  

For QWERTZ or QWERTY keyboards:  

 By using the W, A, S, and D keys you can move directionally (similar 

to the arrow keys).  

 The Space and C keys allow you to move up and down respectively.  

 Use the Q and E keys for rolling around the view axis.  

For AZERTY keyboards:  

 By using the Z, Q, S, and D keys you can move directionally (similar 

to the arrow keys).  

 The Space and C keys allow you to move up and down respectively.  

 Use the A and E keys for rolling around the view axis. 



 

3.4.8. Clipping planes 

Clipping planes are a great tool to reveal the inner structures of objects.  

By hiding all the image information on one side of a clipping plane, it’s 

possible to reveal objects that might otherwise be obscured by their sur-

roundings, without losing the context that the surrounding provides. 

Clipping planes can be added or removed with a single click from within 

the 4D Viewer by using the dedicated buttons in the Viewer Settings 

toolbar. 

The angle of the clipping plane can then be adjusting by clicking and drag-

ging on it using the Selection tool, or by clicking the Alt key while using the 

Rotation tool to temporarily switch to the Selection tool. 
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3.4.9. 4D Clipping palette  

The 4D Clipping palette allows users to change each plane’s visualisation 

options independently of the others and to adjust the clipping settings of 

ROIs as well.  

As with other palettes, right-click in an empty palette space or select it 

from the Window> Palette menu options to activate it.  

The following additional options are available for clipping planes in the 4D 

Clipping palette:  

Show/Hide  

Plane check box 

Check this to show the clipping plane and un-

check it to hide it. This corresponds to the tog-

gles found in the Viewer Settings toolbar 

Visibility / Render-

ing 

Changes how the plane handles the image data. 

Invisible: show no information about the voxels 

on the plane but are transparent to allow visuali-

sation of everything behind it from the point of 

view of the observer. 

Textured / Opaque: show the pixel intensity 

along the plane as measured in the image but 

does not allow the visualisation of anything di-

rectly behind the plane from the point of view of 

the observer. 

Binary / Opaque: as with the textured/opaque 

plane, but pixel intensities on the plane are 

shown in binary (either black or white). 
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Textured / Transparent: Pixel intensities are ren-

dered with the same opacity settings as the 3D 

volume. 

Coloured / Transparent: as with the Textured 

settings, but the plane itself is tinted according to 

the plane outline colour. 

Show/Hide  

Outline check box 

Click to show or hide the edge outline for the 

current plane  

Plane Colour Changes the colour of the outline, and plane tint 

when using the Coloured / Transparent render-

ing.  

Clipping direction Shows or hides volume data either side of the 

plane front and back faces. 

Position/Angle 

sliders 

Adjusts the position and angle of the plane rela-

tive to the plane’s axis.  

Reset Orientation Resets all options relating to the current plane to 

factory defaults. 
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3.4.10. Clipping regions 

The Clipping palette also offers the possibility of clipping around regions 

of interest, which can be useful for analysis or to load a higher resolution 

rendering for a smaller portion of a set.  

Clipping regions can be based on a pre-existing 3D segment, or can be 

manually selected from within the clipping palette.  

To clip around a region, first open the 4D Clipping palette and go to the 

ROI tab. 

3.4.10.1. Clipping from Annotations 

 To clip from an existing annotation, select it in the 4D Viewer or anno-

tations window and check the option to Clip on Selection.  

You can also clip hide everything within the region by using the Invert op-

tion.  

Note that you may also need to hide the annotation to show the result ei-

ther by removing the display or annotations or by switching annotation 

display to bounding box only.  

  



58 

 

 

3.4.10.2. Clipping from a region of interest 

1. To clip to a region, check the Region of Interest option. (1) 

2. Click on Edit Region to open the region of interest selection window. 

(2) 

1.  Then, either type in the start and end coordinate for the region in 

each axis or adjust the sliders to get a visual feedback in the viewer 

of the current selection dimension. (1) 

2. Once happy with the selection, click the Apply button then click OK 

to close the window. (2) 

Note that when using the clipping the software will automatically recalcu-

late the rendering resolution for the selected sub-volume based 4D 

Viewer settings preferences. 
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1 

2 



59 

 

 

3.5. Projection Viewer 

The Projection viewer allows users to see information from a 3D model in 2 

dimensional flat section by compressing or sub sampling the data. It can 

also be used to reorient a set based on the rotation of clipping planes. 

The Projection viewer has three modes: 

 Projection – Compresses the data from multiple planes into a single 

plane 

 Orthoslicer – Renders a single slice through the dataset along one 

of the three main axes 

 Sectional plane – Renders a single slice through the dataset accord-

ing to clipping planes or through manual definition of orientation 

angles 

 

4D Viewer YZ Maximum Intensity Projection 

over Z 

  ZX Slice halfway along the Y axis Oblique Slice 
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The images above show the same sample using the 4D Viewer on the left an 

XY projection over Z on the right, a ZX slice along the Y axis and an obliquely 

oriented sectional plane. 

 

To activate the Projection Viewer, simply click its icon in the Viewer Types 

pane or select it from the View menu options. 

3.5.1. Projection 

1. To create a projection, first select the Projection option from the 

Viewer Settings Toolbar. (1) 

1 
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2. Then, select the axis of projection from the Projection scenario 

dropdown, and the projection mode (Maximum/Minimum). (2)  

The projection mode defines how the data is compressed along the pro-

jection axis. Projection can be done by either displaying he brightest pixel 

along the projection axis (maximum intensity) or the darkest (minimum 

intensity). Different  projections modes or more suited to different types 

of datasets. For example, fluorescence images are typically best displayed 

using a maximum intensity projection. 

 

3. Click the Update button to render using the current settings into the 

viewing area. (3), (4) 

4. To crop the projection to a smaller proportion of the stack, use the 

sliders to adjust the bounds in each dimension as needed. (5) 

5. Check the Auto-Update box to see the changes applied as soon as 

you let go of each slider. (2) 

 

Turn off the auto update if the projection calculation takes too long for 

very large stacks or regions. 

3.5.2. Ortho Slicer 

1. To create an orthogonal slice projection, first select the Orthoslicer 

option form the Viewer Settings toolbar. 
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1. Select the axis of projection from the Projection scenario 

dropdown, then click the Update button to render. 

2. Use the projection sliders to select the slice to display and the 

brackets on the Horizontal and Vertical axes to crop to a smaller 

section of the image. 

3. Check the Auto-Update box to see the changes applied as soon 

as you let go of each slider.  

As with the Projection mode, avoid using this option for very large stacks 

as the rendering could take a long time. 
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3.5.3. Sectional Plane 

1. To create a sectional plane projection, first select the Sectional plane 

option form the Viewer Settings toolbar. 

 

2. Then, select from the available sectional planes already defined 

within the 4D Viewer, or select the manual option to manually define 

the position and orientation of the sectional plane. 

3.5.4. Extracting projections 

In any projection mode, you can use the Save As … button (below the Up-

date button), to save the resulting 2D plane as a new SIS file or a new scope 

within the current file.  

When used in conjunction with sectional planes the Save function can also 

be used to reorient the set by saving a complete stack rotated according to 

the sectional plane. 

You can also use create a snapshot of the current view by going to the Edit 

menu and selecting the option to Copy Viewer Screenshot content.  

This will copy the current rendering to the clipboard and allow you to paste 

it into another application (e.g. word processing, presentation).  

Note that the option to copy viewer screenshot content is available in all 

rendering modes. 
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3.6. Split view 

The split view allows users to visualise multiple images simultaneously, 

whether these are different renders of the same image or different scopes 

from the same set.  

Note that the split view can only work with different scopes or image re-

gions of the same document opened with the same Viewer window.  

Visualising images from different documents will require that they be im-

ported into the same SIS file first.  

 

3.6.1. Changing the number of viewers in the Viewing Area 

1. To change the numbers of viewers in the Viewing Area, click on the 

split view button corresponding to the number and layout of viewers 

you want. (1)  

  

1 
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Users can switch back and forth between any viewer configurations at will. 

 Single viewer 

 Two viewers, split left/right 

 Two viewers, split top/bottom 

 Three viewers side by side 

 Four viewers rectangular grid (2x2 

 Six viewers rectangular grid (3x2) 

 Nine viewer rectangular grid (3x3) 

 

Once you have multiple viewers displayed you can set the view for each in-

dividually.  

Simply click within on the viewer’s title bar or body to activate it then 

change any of the parameters as required (change view style, scope etc.).  

3.6.2. Linking viewers 

Linking viewers is a great way to compare between scopes within a file or 

between rendering modes for a single scope.  

To ensure that the views match each other in terms of orientation and po-

sition, it is possible to link all the viewers together and arivis Vision4D will 

automatically adjust each viewer to match changes made by the user in any 

one viewer.  

 To enable linking of viewers, click the chain-link icon at the bottom left 

of the Viewing Area. (2) 

 To disable linking, click on the crossed out chain-link icon in the bot-

tom left of the Viewing Area. 

 

 Link subviewers 

 Unlink subviewers 
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Clicking on the drop-down arrow to the right of the linking button gives 

additional options regarding what aspects of the subviewers should be 

synchronised. 

The example below shows three different scopes from the same SIS file, 

each in the 4D Viewer with linked 3D positions. 

 



 

3.7. Sharing images 

arivis Vision4D provides a range of tools to share the visual insights that 

can be gained from manipulating the data outside of the software by ena-

bling the export of high resolution animation movies and snapshots.  

Animations can render changes in viewing angle, zoom level, position and 

visibility of clipping planes and various rendering options (e.g. transpar-

ency, black/white levels). 

3.7.1. Sharing viewer content 

In any most viewer types (2D/4D/Projection), you can create a snapshot of 

the current view by going to the Edit menu and selecting the option to 

Copy Viewer Screenshot content. This will copy the current rendering to the 

clipboard and allow you to paste it into another application (e.g. word pro-

cessing, presentation). 

This tool is effectively a screen copy that uses the current screen display 

mode and resolution and can only be used for a single view and time point.  

For more flexibility and higher resolution options, please see the snap-

shots and movie export options below. 

3.7.2. Sharing High Resolution Snapshots 

To export a single point of view with a specific rendering, including deco-

rations (annotations, clipping planes), you can use the High Resolution dia-

log.  

Whereas the arivis Vision4D rendering engine may load lower resolutions to 

enable the software to render 3D objects quickly enough to be interactive, 

the snapshot tool can load as much image information as can be displayed 

at the user’s selected output resolution, resulting in much higher resolu-

tion, publication quality images. Because the snapshot tool loads a lot 
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more information, the process of rendering these high resolution images is 

comparatively much more time consuming. 

 To create a high resolution snapshot, go to the View menu and select 

the High Resolution Image option, or click on the Camera icon          

in the shortcut toolbar, this will open the High Resolution Rendering 

window. 

1. Choose an image and data resolution (1) 

 

The image resolution defines the size of the output image.  

The data resolution slider affects the quality of the rendering.  

Data resolutions within the green range of the sliders can be loaded into 

the video memory for very fast rendering. 

Data resolutions within the yellow segment will fit within the system 

memory for fast rendering. 

Data resolutions in the red segment will not fit in either video or system 

memory requiring occasional reloads and causing slow renderings.  

 

2. Choose an export target. (2) The Export Target allows you to se-

lect the intended target for the rendering. You can choose be-

tween the predefined options Screen (96 dpi), Low Resolution 

Printer (150 dpi) and High Resolution Printer (600 dpi) or specify 

a custom dpi value.   

1 

2 

3 
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3. Click Finish to confirm your selections and the software will ren-

der the image as selected. You can then save the image if satis-

fied with the results. (3) 

 

Note that the higher the data resolution the longer the rendering takes. 

 



 

3.7.3. Sharing Movies - The Storyboard 

The storyboard is an extension of the 4D Viewer through which users con-

figure animations to be rendered as a movie for exports. It works through 

the concept of adding, removing and arranging “key frames” that are specific 

rendering of the 3D model, and then interpolates between those positions 

to create an animation. 

Like a Bookmark, a key frame contains the following properties from the 

current scene: 

 Time point from dataset 

 Camera position and rotation 

 Channel visibility and opacity 

 Clipping planes and their various properties 

To open the storyboard, click on the Storyboard icon  in the Shortcut 

toolbar. (1) 

The Storyboard palette will then open at the bottom of the workspace and 

is initially empty. 

Once the Storyboard is opened, simply add, remove or otherwise rearrange 

key frames to define the animation trajectory. 

 

1 

2 

3 

4 



 

3.7.4. Key frames and sequences 

1. To add key frame to the Storyboard, start in the 4D Viewer by setting 

up the details of the orientation and view that you want to display in 

your animation sequence. 

2. Then, click the Add Key Frame link in the Storyboard, or click the 

Add Key Frame icon from the Storyboard toolbar. (1) 

3. Modify the rendering of your 3D volume (orientation, zoom, map-

ping…) and add more key frames as needed. Each key frame will be 

added to the end of the existing key frames in the storyboard. Snap-

shots of the Key Frames renders will appear in the Storyboard. (3) 

arivis Vision4D can automatically generate sequences of motion, like rotat-

ing the 3D model through 360 degrees.  

 To add a sequence, click the Add Sequence link in the storyboard or the 

add sequence icon  in the storyboard toolbar. This will open the se-

quence definition window.  

1 
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1. Select the sequence Duration; this is the time it will take in the ren-

dered movie to progress through the sequence. (1)  

2. If you want to rotate the 3D view, click to check the Create Rotation 

check box and define the rotation options. (2) 

3. If you want to add frame progression (playback through time 

frames), also check the Use Frame Progression check box.  

4. Use the sliders to select the first and last frame in the frame pro-

gression. (3)  

Note that the frame progression option is only available for scopes that 

have multiple frames. 

5. Click the Add Sequence button and the software will automatically 

create all the interstitial frames required to render the sequence as 

selected. (4)  

Note that for a rotation through 360 degrees, four key frames will be cre-

ated.  

If a key frame has been added in error, or is no longer needed, you can de-

lete them by clicking on the cross icon  on the top right of the key 

frame in the storyboard.  

1 

2 

3 

4 
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6. To modify a key frame, select it by double clicking on it in the story-

board, then adjust the rendering as needed in the viewer.  

7. Finally, click on the replace key frame icon  on the top left of the 

key frame in the storyboard.  

8. To change the order of the animation sequence, click and drag the 

key frame you want to move to the position you prefer within the 

storyboard. 

 

Every key frame (except the last one) will have a transition to the next key 

frame. You can specify how the individual key frame properties will be an-

imated during the transition to the next key frame. 

 

9. To edit animations presets, adjust the options as required by select-

ing the key frame you want to modify and changing the parameters 

in the key frame options.(4)  

 

Please refer to the manual for the complete run down of the frame transi-

tion properties. 
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3.7.5. Exporting movies 

Throughout the process of creating and editing your animation sequence, 

you can use the playback buttons at the top of the storyboard to review 

your work.  

The software will execute a fast render of the key frames and transition to 

play through the sequence in “real time”. Once you are satisfied with your 

animation sequence, you can create a high resolution rendering of your 

movie as a movie file that can be imported in most media players and 

presentation software.  

 To export your animation, click on the Export movie icon   in the 

storyboard toolbar, which will open the export window. 

1. Set up your export options as needed by choosing a name and ex-

port location, video format, resolution and frame rate, and the ren-

der quality.(1), (2), (3), (4)  

 

1 

2 

3 

4 

5 
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As with the high resolutions snapshot tool, the data resolution slider’s 

color reflects the amount of memory required to render individual frames 

in the animation.  

When the slider is Green, individual frames can be processed in the video 

memory for very fast rendering. When Yellow it will use system memory 

for fast rendering (though slower than when using video memory), and 

when Red will not fit in either causing occasional reloads and slow ren-

derings. 

Avoid unnecessarily high render quality settings to save time in the ren-

dering process.  

 

2. If so desired, you can choose to display a time stamp in your ex-

ported movie file by selecting your preferred option in the 

Timestamp Position droplist box. (5) 

3. When ready, click Record to create and save your movie to the previ-

ously selected location.  
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4. Image processing and analysis 

Image processing and analysis allows the user to reveal the information 

contained within an image. This includes a range of tools and techniques to 

produce qualitative and quantitative data and generally falls under two cat-

egories with significant overlap: image enhancements and data analysis. 

Image enhancement tools generally have two intended results, to make 

specific parts of the image information more easily visible and to facilitate 

the analysis. 

arivis Vision4D offers a range of tools, some of which are optional, for im-

age analysis and processing. Details of the use of these optional features 

are not covered in this guide. 
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4.1. The Filter Gallery 

The Filter Gallery provides an interface for selecting, previewing and applying 

filters to an image.  

 To open it, go to the Analysis menu and select the Filter Gallery-option. 

The Filter gallery is divided into three sections: 

 The Preview area – where users can preview the effect of filters on 

the image. (1) 

 The Available Filters list – where users can choose what type of filter 

to apply to the image. (2) 

 The Filter Parameters – where users can adjust the region of the im-

age to apply the filter to and the various parameters related to the 

chosen filter. The filter parameters area also includes a filter de-

scription for the selected filter, and an explanation of the effect of 

the selected filter parameter. (3) 

 To preview a filter, first select it from the list of available filters. The 

available filters are sorted into the following categories: 

 Denoising – these generally work by blurring small features. Some 

specifically avoid affecting edges while others use local variance to 

affect those pixels only within a certain threshold of the local inten-

sities. 

 Edge Detection – these detect gradients in the image and highlight 

their locations. 

1 

2 

3 
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 Enhancements – these generally attempt to process the image so 

that the results look closer to the assumed real data assuming per-

fect conditions. For example, background correction filters estimate 

what the image would look like without a sample in the optical sys-

tem to calculate what an image of the sample would look like with 

perfectly even illumination. 

 Intensity – mostly affect pixels based on their intensity within the 

general context of the image rather than their immediate neighbour-

hood. For example, threshold filters analyse the image to identify a 

threshold to differentiate between what some consider objects and 

background. 

 Morphology – Filters that look to enhance the image by using the 

shape of structures within the image. 

Once you’ve selected a filter, its description will appear on the right, with 

the parameters available to tune its effects, and a preview will appear on 

the left.  

The preview can be modified to show the results on the whole image 

zoomed to fit, or on the central region at 1:1 screen pixel to image pixel 

ratio.  

The preview window can also be split left/right top/bottom with before/af-

ter renditions of the image. 

For a full run down of each filter, please refer to the help files.  

Remember you can use the F1 key on your keyboard for quick access to 

the help page on any topic. 

 

  



 

5. Saving and exporting images 

Once you have made changes to an image, whether these only affect the 

visualisation or include more significant changes like masking, annotation 

or filters, it is necessary to save your images to preserve your work. 

The import process automatically creates a SIS file, but the user must 

choose whether to keep or discard this file when closing. Note that if you 

do not save your file when closing, the entire import process will be nec-

essary and all changes will be lost the next time you want to open these 

images. 

Several options are available depending on your future intended usage of 

the image data. 

5.1. Saving images for use in arivis Vision4D 

If the images are to be reopened within arivis Vision4D then images should 

always be saved in the native SIS format.  

Files saved in this format will maintain all aspects of the visualisation (e.g. 

LUT adjustments, colour scales), any changes to the metadata (e.g. pixel 

size), but can also include analysis pipelines and annotations. 

 To save an image in the SIS format, simply go to the File menu and se-

lect the Save option or press the Ctrl-S key combination on your key-

board. 

Note that the option to save images is only available if changes have been 

made to the image since it was opened or created and will be greyed out 

in the file menu otherwise. 

5.2. Saving images for use in other imaging packages 

Having processed an image set within arivis Vision4D, users may wish to 

export those images to other imaging packages that do not have support 

for the SIS file format.  

If that is the case, you should use the export function to save the image to 

a standard image file. 

arivis Vision4D can export files to a variety of formats, including TIFF, PNG, 

JPEG, AVI and more depending on the needs. 
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 To export an image to another format, go to the File menu and select 

the Export option. You will be presented with the Export window where 

you can select what type of export you want to use. 

 If you wish to export the images for inclusion into text documents, 

posters or presentations, you should use the Movie or Multi-format Ex-

porters.  

 If you want to export the images for analysis in another package, you 

should use the SIS Stack or TIFF exporters. 

 The Movie and Multi-format Exporters both offer the option to save the 

images with annotations written to the pixel data so that they can be 

visible in any software package that can display the images.  

 The SIS File Exporter and TIFF Exporter allows to export images at their 

native bit depth with the metadata to ensure data integrity, though bear 

in mind that not all imaging packages that open TIFFs look for the 

same metadata in the same structure which may cause some slight 

problems in the case of calibrations for example. 
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For full details of each exporter, please refer to the help files.  

Remember you can use the F1 key on your keyboard for quick access to 

the help page on any topic. 
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6. Example workflows 

6.1. Import a time series 

Use the images in Import/Time Frames from http://demodata.arivis.com. 

1. Go to File> Import and navigate to the Time Frames folder. Select all 

the image files contained within and then click Open. 

2. Select the source folder as the destination and select the Images as 

Frames import scenario and click OK. 

6.2. Import and rearrange a dataset with a complex file struc-

ture using pattern matching 

Use the images in Import/Complex from http://demodata.arivis.com. 

1. Go to File> Import and navigate to the Complex folder. Select all the 

image files contained within and then click Open. 

2. Select the source folder as the destination and rename the file to 

Spindle, then, select the Custom Import option from the import sce-

narios and click OK. 

3. Go to Selection> Pattern matching to open the Import Pattern 

Matching window. 

4. Change the Pattern to spindle%c_P_S%i_S%i_T%f_Z%p_C%c, this will 

ensure that first two numbers in the file name are ignored, the num-

ber next to T corresponds to the frame, the number next to Z corre-

sponds to the plane, and the number next to the C corresponds to 

the channel. Click the Refresh button next to the pattern name to 

check that the allocations are correct. 

5. Click OK to confirm and close this window and return to the Manual 

Import Mapper window. 

6. Check that the save location and image allocation is correct then 

click OK to complete the import process. 

  

http://demodata.arivis.com/
http://demodata.arivis.com/
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6.3. Import and rearrange a complete set with tiles 

Use the images in Import/Mosaic Tiles from http://demodata.arivis.com. 

1. Go to File> Import and navigate to the Mosaic Tiles folder. Select all 

the image files contained within and then click Open. 

2. Select the source folder as the destination and rename the file to 

Tile, then, select the Tile Sorter option from the import scenarios 

and click OK. 

3. Once the set is imported the tile sorter will open. Set the order to 

Straight and Rows. Make sure that the starting position is set to Top 

Left. 

4. Set the number of Frames to 1, Planes to 1, Columns to 25 and Rows 

to 26. 

5. Zoom in to 100% at the boundary between four tiles within the tissue 

section and adjust the displacement and overlap until satisfied that 

the images match. 

6. Click Create Stitched Planes… to open the Stitch Tiles Dialog. 

7. Set the output to New Scope and leave the rest of the default options 

unchanged. 

8. Click Finish to confirm and stich the tiles according to the previously 

selected parameters. 

http://demodata.arivis.com/


 

6.4. Create an animation to reveal structures of interest 

Use demo set “Sea Urchin” from http://demodata.arivis.com. 

1. Go to File> Open and select the Sea Urchin data set into arivis Vi-

sion4D.  

2. Use the Viewer Types switch on the left of the Viewer Settings 

toolbar to switch to the 4D viewer. 

3. Right-click on the colour scale to switch the color to the rainbow 

scale. 

4. Switch the rendering mode to Volumetric from the workspace 

toolbar. 

5. Use the sliders on the color scale to adjust the transparency of the 

black level and the threshold of the volume surface. 

6. Use the Home View icon from the Shortcut toolbar to reset the ori-

entation to the default orientation. 

7. Click on the Storyboard icon  in the Shortcut toolbar to open the 

Storyboard. 

8. Add the current orientation as a key frame to your storyboard. 

9. Use the fly-through mode to navigate towards the sample so that 

you are facing the “mouth” of the object, then add this orientation as 

a key frame in the Storyboard. 

10. Use the fly-through mode to navigate to the centre of the object and 

add this view as a key frame in the Storyboard. 

11. Use the fly-through mode to rotate the view through 180 degrees 

and reverse out of the object then add that view as a key frame in 

the Storyboard. 

12. Rotate the object so that you are viewing it ‘side on’ and add another 

key frame to the storyboard. 

13. Add a clipping plane to the 4D Viewer and orient it so that it bisects 

the object. Then, adjust the position so that it no longer cuts the 

objects and add another key frame. 

14. Move the clipping plane back to its bisecting position and add a final 

clipping plane. 

15. Click the Export Movie button.  

16. Set the movie resolution to 1280x720 and the data resolution to the 

last green setting before it turns yellow.  

17. Set your export location then click Export. 

18. Try importing your movie into a presentation or playing it back on 

another computer. 

http://demodata.arivis.com/
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Glossary 

ANNOTATION:  Any additional element on an image that is not pixel 

data. Annotations are used both for illustration and measurements 

BIT DEPTH:  This defines the degrees of variation between the 

minimum and maximum intensity values in the image. Typically, this 

is dictated by the acquisition device used to generate the images and 

is stored in computer systems as a number of ‘bit’. Higher bit depths 

have more degrees of variation but require more computer memory 

for processing and storage. An 8bit image stores values between 0 

and 255 for each pixel and each pixel requires 1 byte of memory for 

storage and processing. A 16bit image stores values between 0 and 

65535 for each pixel and requires 2 bytes of memory. Note that when 

talking about colour images the usage of “24bit colour” is common, 

but what is usually meant is 8bit per channel. 

BOOKMARK:  Bookmarks are a record of the current visualisation 

parameters for your data. They capture the current scene settings 

(e.g. render mode and view properties) and save them for later use. 

Bookmarks are stored in the metadata of the document and can be 

shared by exporting them to a proprietary file format (*.bookmarks). 

Bookmarks can be transferred between different data sets and instal-

lations of the software. 

DIMENSION:  The coordinates required to define the location of 

each pixel in a set. The SIS file supports the following dimensions: 

SCOPE:  This dimension is used to contain all the other dimen-

sions relating to a discreet sample. Multiple scope can be 

used to contain different wells in a plate, or different states 

of a scope (e.g. as the result of a filtering operation), or dif-

ferent components belonging to the same data set.               

CHANNEL: The channel dimensions stores the different modali-

ties or colours of a set. It is most useful in fluorescence mi-

croscopy where each fluorochrome is stored as a discrete 

monochrome channel and can be displayed independently of 

the others or overlayed to show the correspondence between 

channels. 

FRAME:  The time element of a series. Each time point is a dif-

ferent frame. The frame information is important for tracking 

operations and monitoring changes over time.  

PLANE:  A 2-dimensional matrix of intensity values for all 

points at a specific depth position in the sample. 

FEATURE (of segments): Features are calculated characteristics for Seg-

ments/Tracks/Annotations (they are calculated and are only available 
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when you do analysis operations), often referred to as measure-

ments. 

FILE:   A document containing data that can be shared, cop-

ied or deleted from the Windows File Explorer. Files can typically be 

opened and edited within dedicated applications. Files that can be 

opened in arivis Vision4D can be classified in two categories: 

 NATIVE FILES:  Files that are created and read by arivis Vi-

sion4D. These files are labelled with the extension .SIS in the case of 

image files, for ‘Single Image Stack’. This type of file enables the 

arivis arivis ImageCore technology at the heart of arivis Vision4D. 

Non-native files must first be imported into an SIS file to be opened 

into arivis Vision4D.  

 NON-NATIVE FILES: Supported files can be imported into an SIS file 

for processing. Supported files include most common image files, in-

cluding TIFF, BMP, JPEG, DICOM, and many proprietary microscopy 

file formats including CZI (Zeiss), LIF (Leica), OIB (Olympus), ND2(Ni-

kon), and many others besides. Users can check the complete list of 

supported file formats from the Help documentation and from the 

Import File selection window. 

IMPORT:   The process by which images are converted to the SIS 

format. It is the first and necessary step for any non-native file sup-

ported in arivis Vision4D (anything other than SIS). This enables the 

use of the Image Core technology at the heart of Vision4D.  

OPEN:   Only available for SIS files. This makes the image data 

in a file available in the software workspace. 

PALETTE:  A user interface element that contains information 

and adjustments relating to a specific aspect of an image or image 

object (e.g. all properties relating to a clipping plane). 

PIXEL / VOXEL:  Pixel is short for Picture Element. It is the smallest in-

dividual component of an image. Each pixel represents an intensity 

value / measurement within the context of the 2 dimensional matrix 

that is the plane of an image. The dimension of a pixel extends from 

the edge of a pixel to the edge of the next. Voxels are the pixel 

equivalent of a 3D volume and extends in Z as well as X and Y. 

PIXEL DIMENSION: A calibration value that allows the software to convert 

measurements from an image from a number of pixels to real world 

units. Typically defined as the distance from the centre of one pixel 

or voxel to the centre of the next. 

PROPERTIES:   Properties are characteristics of annotations or image 

data. In contrast to features, they are always there and part of the 

model and saved with the image data.  

RENDER:  How the image pixel intensity data is displayed on the 

screen. The rendering modes are dependent on the selected viewer  

http://www.arivis.com/en/imaging-science/import
http://www.arivis.com/en/imaging-science/import
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type and affect what portion of the image data can be visualized. 

Vision4D supports various rendering modes implemented in viewers 

including 2D plane, 2D projection and 3D views. 

RESTORE POINT:  The arivis ImageCore file format provides versioning 

capabilities that are used for a comfortable undo/redo handling as 

well as for the specific creation of long-lasting versions of your image 

data within one .SIS file. A single restore point stores your entire im-

age data, the available metadata and the created annotations. There-

fore, it can easily support different filter and analysis experiments. 

SEGMENT:  An annotation or objects derived from analysis steps 

resulting in segmentation of an image or the manual annotation of 

an image.   

STACK (also Z-stack):  A series of images planes representing a 3D object 

data.  

VIEWING AREA:   The part of the user interface that displays the set 

data. The viewing area can display the set in various modalities (2D, 

3D, Info viewer) and also displays previews of the effect of analysis 

or filtering operations as well as the visual representation of the re-

sults of such operation. 

Viewer:   A single window in which a single SIS file can be dis-

played and processed. It contains all the tools required to render and 

interact with a SIS file. Viewers can be set to display the content of 

the SIS file in any of several rendering modes, including 2D, 4D, Pro-

jection etc.  

WORKSPACE:   The layout of the tools and palettes within the appli-

cation window. Workspaces can be saved to quickly change between 

different combinations of tools and palettes related to a specific 

workflow. 

 



 

FAQs 

How can I improve the render quality for my images?: 

The quality of the 3D renderings is highly dependent of your graphics card, 

your PC configuration and software configuration.  

When the 4D Viewer first runs after the installation of the software it will 

perform an automatic hardware check and optimise settings according to 

the results. However, users may choose to sacrifice some speed to improve 

the render quality while interacting with the data. To do this, you will need 

to change the 4D Viewer preferences. 

To access the 4D Viewer preferences, go to the Extras menu and select the 

Preferences option. In the Preferences window, expand the Viewers tab and 

select the 4D Viewer tab.  
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Adjusting the Sampling and Resolution sliders will Improve or reduce the 

quality of the render. Higher quality will normally result in slower rendering 

speeds. 

 

I have a high spec graphics card but the renders appear to be of low reso-

lution:. How can I make sure the software is making the most of my hard-

ware? 

When running arivis Vision4D on most laptops and some desktops, Win-

dows attempts to reduce the power requirements by only enabling the use 

of dedicated graphics hardware if specifically requested to do so by the 

user. User can force the use of the graphics card by right-clicking on the 

program icon or shortcut and selecting which graphics processor to use the 

application from the contextual menu. 

 

It is also possible to change the default for specific programs, although the 

interface for this will depend on the device manufacturer. 

If you’ve run the 4D Viewer for the first time and the auto detect was run 

without the use of your preferred graphics hardware, you can rerun the au-

tomatic detection from the 4D Viewer preferences. 

In the 4D Viewer tab of the preferences window, click the Run Auto-Detec-

tion… button and wait for the process to complete.  



91 

 

 

Any images displayed in the 4D Viewer should automatically reload, but 

you may need to change out of the 4D Viewer and back in for change to 

take effect. 

If this does not improve the quality of the render, or if the 3D render 

simply fails to appear, you should also check your hardware configura-

tion. Makes sure that your drivers are up to date and also make sure that 

your monitor is connected to your graphics card and not to your mother-

board graphics connector. 

 

 

Where can I change the default directory for data export? 

By default arivis Vision4D will save new documents (SIS files, bookmarks, 

movies etc) to the user’s Documents folder. To change this default, go to 

the Extras menu and select the Preferences option. 

In the Preferences window, select the General tab and you’ll find the default 
directories for new documents and scripts.  

To change the default new document location, either click the Select… button and 
navigate to your preferred location, or simply type the path of your save folder in 
the text box. 
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A note on large images: 

Throughout this guide we make mention of “large data sets”, with many 

implications regarding processing speeds and rendering quality. The defi-

nition of what constitute as “large set” is, however, somewhat dependent 

on the configurations of your workstation and the operation that is re-

quired. 

The ImageCore technology is designed to enable the fast visualisation of 

sets of almost any size. This is done by enabling the software to access any 

part of the image at will without the need to access the full image data. 

This process is particularly well suited to the rendering of images where in 

any case most systems do not have the capability to display the complete 

document data, whether this is because the screen itself is two-dimen-

sional whereas arivis Vision4D can handle up to 5 dimensions, or simply 

because most computer displays only have in the region of 2 to 8 million 

pixels whereas some sets can be several orders of magnitude larger. 

The 4D Viewer will automatically analyse the configurations of the PC 

(graphics card, available memory) to calculate an optimal scaling resolution 

for fast rendering of the data and is therefore relatively immune to the 

overall size of the data. However, rendering of segments within a 3D set 

can be quite slow in comparison, especially if there are many small objects 

or the surface geometry is very complex. Again, what is meant by “many 

objects” and “complex geometry” is somewhat dependent on the computer 

specification.  

Analysis operations, especially those concerned with filtering or segment 

generation, usually require the software to access and process each and 

every single pixel concerned within the selected region. In 8bit images, 

each pixel represents one byte of memory usage and in 16bit, each pixel 

needs two bytes. A 1 megapixel image will therefore require 1 megabyte of 

memory. If a stack contains multiple planes, the amount of memory re-

quired to process the entire stack will be equivalent to the number of pixel 

in each frame multiplied by the number of planes in the stack. Some oper-

ations can process each plane individually (e.g. 2D filters and threshold 

based segmentation), while others will require multiple planes (e.g. blob 

finder and 3D filters). Typically, operations that require less than 25% of 

the available system memory can be executed relatively quickly, while 

larger tasks may be slowed down by the use of virtual memory and the 

need to cache data. 
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Also, while where possible arivis Vision4D will make use of multiple pro-

cessors to process more of the data at any one time, not all processes can 

be parallelised.  

Discussing the exact requirements of each type of operation and the effect 

of various hardware choices would take much too long for this guide. So, 

while there is no hard and fast definition of what constitutes a “large set”, 

considering the amount of physical memory necessary to process a plane, 

frame or scope compared to the amount of memory available from the sys-

tem can be a good indication. Generally, expect sets that represent more 

than 25% of the available system memory to take significantly longer to 

process. 
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